Known Issues

From Etp
Jump to: navigation, search

Subversion

Ubuntu 14.04 is shipped with subversion v1.8.8, whereas slc6 comes with v1.6.11. Between these two versions the repository structure has changed so that they are incompatible. Old repositories can be upgraded using the svn upgrade command, but beware that there is no way to undo this and upgraded repositories can no longer be read under older svn versions:

svn: The path '.' appears to be part of a Subversion 1.7 or greater
working copy.  Please upgrade your Subversion client to use this
working copy.

RootCore relies on subversion to gather information about the packages you are using and will thus fail when encountering an upgraded repository somewhere in the upper directories.

Solution

A new subversion client has been made available under slc6 and schroot via the module system. It can be loaded via

module load subversion/1.8.8